Spring boot Spring System Requirements and compatibility

Spring boot 1.5.6 Spring System Requirements and compatibility

Java compatibility

Spring boot is compatible with Java 1.6, but consider using latest version

Maven or Gradle

Spring Boot is compatible with Apache Maven 3.2 or above, Gradle 2.9 or above

Container

Any servlet 3.0+ compatible container

Example : Tomcat 7 or above , Jetty 8 or above

Spring Framework

Spring Framework 4.3.10.RELEASE or above

Note:

If you are using tomcat 7 then servlet version should by 3.0 and java 6 or above

If you are using tomcat 8 then servlet version should by 3.1 and java 7 or above

Leave a Reply

Your email address will not be published. Required fields are marked *